PlotSettingsValidator Class

This class defines access methods that validate data for plot settings prior to setting the data on the objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesPlotSettingsValidator

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class PlotSettingsValidator : DisposableWrapper

The PlotSettingsValidator type exposes the following members.

Properties
  Name Description
Public propertyStatic member Current Property that represents the current item.
Top
Methods
  Name Description
Public method GetCanonicalMediaNameList Returns a collection of canonical (locale-independent) media names for the specified PlotSettings object.
Public method GetLocaleMediaName(PlotSettings, Int32) Returns the locale-dependent media name for the specified PlotSettings object and index.
Public method GetLocaleMediaName(PlotSettings, String) Returns the locale-dependent media name for the specified PlotSettings object and retrieves its canonical name.
Public method GetPlotDeviceList Returns a collection of all available system printers and PC3 files.
Public method GetPlotStyleSheetList Returns a collection of all available plot style tables.
Public method RefreshLists Refreshes the plot device and style lists for the specified PlotSettings object.
Public method SetCanonicalMediaName Sets the canonical (locale-independent) media name for the specified PlotSettings object.
Public method SetClosestMediaName Sets the media name closest to the specified parameters for the specified PlotSettings object.
Public method SetCurrentStyleSheet Sets the current style sheet for the specified PlotSettings object.
Public method SetCustomPrintScale Sets the custom print scale for the specified PlotSettings object.
Public method SetDefaultPlotConfig Applies the default plot configuration settings to the specified PlotSettings object.
Public method SetPlotCentered Controls centering of the plot for the specified PlotSettings object.
Public method SetPlotConfigurationName Sets the plot device and media names for the specified PlotSettings object.
Public method SetPlotOrigin Sets the plot origin offset for the specified PlotSettings object.
Public method SetPlotPaperUnits Sets the plot paper units for the specified PlotSettings object.
Public method SetPlotRotation Sets the plot rotation for specified PlotSettings object.
Public method SetPlotType Sets the plot type for the specified PlotSettings object.
Public method SetPlotViewName Sets the plot view name for the specified PlotSettings object.
Public method SetPlotWindowArea Sets the corners of the plot window area for the specified PlotSettings object.
Public method SetStdScale Sets the standard scale for the specified PlotSettings object.
Public method SetStdScaleType Sets the standard scale for the specified PlotSettings object.
Public method SetUseStandardScale Controls the use of a standard scale for the specified PlotSettings object.
Public method SetZoomToPaperOnUpdate Controls the Zoom to Paper on Update setting for the specified PlotSettings object.
Top
See Also

©  Bricsys NV. All rights reserved.