SurfaceSurfaceIntersectorIntersectParameterCurve Method

Retrieves the 2D curve representing the specified intersection.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Curve2d IntersectParameterCurve(
        int number,
        bool isExternal,
        bool isFirst
)

Parameters

number  Int32
[in] The zero-based index of the intersection curve to return.
isExternal  Boolean
[in] Flag that specifies whether to return a handle to an external curve (not implemented).
isFirst  Boolean
[in] If true, returns the curve on the first surface, otherwise it returns the curve on the second surface.

Return Value

Curve2d
Remarks
This method throws one of the following exceptions if the method fails: * kXXIndexOutOfRange - Index out of range. * kXXWrongDimensionAtIndex - Wrong dimension at index. * kXXUnknown - Intersector is not initialized.
See Also

©  Bricsys NV. All rights reserved.