Curve2dIsDegenerate(Entity2d,
Tolerance) Method
|
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsDegenerate(
out Entity2d result,
Tolerance tolerance
)
Public Function IsDegenerate (
<OutAttribute> ByRef result As Entity2d,
tolerance As Tolerance
) As Boolean
public:
bool IsDegenerate(
[OutAttribute] Entity2d^% result,
Tolerance tolerance
)
member IsDegenerate :
result : Entity2d byref *
tolerance : Tolerance -> bool
Parameters
- result Entity2d
- [out] Retrieves the type of degenerate entity.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if this curve is degenerate,
false otherwise.
See Also