DBObjectHandOverTo Method
|
Replaces this database-resident (DBRO) object
with the specified non-database-resident (NDBRO) object, while
retaining this object's objectId, handle, owner, and reactor
list.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void HandOverTo(
DBObject newPointer,
bool keepXData,
bool keepExtensionDictionary
)
Public Sub HandOverTo (
newPointer As DBObject,
keepXData As Boolean,
keepExtensionDictionary As Boolean
)
public:
void HandOverTo(
DBObject^ newPointer,
bool keepXData,
bool keepExtensionDictionary
)
member HandOverTo :
newPointer : DBObject *
keepXData : bool *
keepExtensionDictionary : bool -> unit
Parameters
- newPointer DBObject
- [in] Pointer to the object with which to replace this object in
the database.
- keepXData Boolean
- [in] Flag specifying whether to retain this object's
XData.
- keepExtensionDictionary Boolean
-
Remarks
This object must
be opened in ForWrite mode. The
replacement object is opened in ForWrite
mode, and it must be closed. Throws: ExceptionCauseeIllegalReplacement This object is an NDBRO or
newPointeris DBRO.
See Also