DBObject Class

This class is the base class for all objects contained in a Database instance. An object can be opened in any one of the following modes:
Mode Description
OpenMode.ForRead Allows operations that do not modify this object. A database object can be opened in this mode any number of times (simultaneously), if it is not opened in ForWrite or ForNotify mode. An exception is thrown if any type of write operation is attempted on an object opened in this mode.
OpenMode.ForWrite Allows read and write operations to be performed on this object. The database object can be opened in this mode only if it is not already opened in any mode.
OpenMode.ForNotify A database object cannot be opened in this mode more than one time simultaneously, but it can be opened in ForNotify mode if it was already opened in ForRead or ForWrite modes, or it was closed before.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            More

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class DBObject : Drawable

The DBObject type exposes the following members.

Constructors
  Name Description
Protected method DBObject Initializes a new instance of the DBObject class
Top
Properties
  Name Description
Public property AcadObject  
Public property Annotative  
Public property ClassID  
Public property Database  
Public property Drawable Property that represents a drawable that is associated with this object.
Public property ExtensionDictionary  
Public property Handle  
Public property HasFields  
Public property HasSaveVersionOverride  
Public property Id Property that represents an object identifier of this database object.
(Overrides DrawableId)
Public property IsAProxy  
Public property IsCancelling  
Public property IsErased  
Public property IsEraseStatusToggled  
Public property IsModified  
Public property IsModifiedGraphics  
Public property IsModifiedXData  
Public property IsNewObject  
Public property IsNotifyEnabled  
Public property IsNotifying  
Public property IsObjectIdsInFlux  
Public property IsPersistent Property that indicates whether this object is a database-resident (DBRO). Persistent objects belong to an object that must be opened and closed. Non-persistent objects can be accessed through their pointers.
(Overrides DrawableIsPersistent)
Public property IsReadEnabled  
Public property IsReallyClosing  
Public property IsTransactionResident  
Public property IsUndoing  
Public property IsWriteEnabled  
Public property MergeStyle  
Public property ObjectBirthVersion  
Public property ObjectId  
Public property OwnerId  
Public property PaperOrientation  
Public property UndoFiler  
Public property XData  
Top
Methods
  Name Description
Public method AddContext Adds a copy of a context to the object.
Public method AddPersistentReactor Adds the specified persistent reactor to this object's reactor list.
Public method ApplyPartialUndo Notification method that is called each time this object uses the partial undo mechanism.
Protected method AssertNotifyEnabled  
Protected method AssertReadEnabled  
Protected method AssertWriteEnabled  
Public method Audit Performs an audit operation on this object.
Public method Cancel Obsolete.
Terminates the current open operation. Currently not implemented.
Public method Close Obsolete.
Closes the object. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented.
Public method CloseAndPage Obsolete.
Closes the object and pages it if the object pager is enabled. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented.
Public method CreateExtensionDictionary Creates a DbDictionary extension dictionary of this object.
Public method DecomposeForSave Determines the behavior for custom objects when saving to a .dwg file.
Public method DeepClone Performs a deep clone of this object.
Protected method DeleteUnmanagedObject
(Overrides RXObjectDeleteUnmanagedObject)
Public method DisableUndoRecording Controls the undo recording of this object in OdDbDatabase.
Protected method Dispose(Boolean) Releases the unmanaged resources used by the DBObject and optionally releases the managed resources
(Overrides DisposableWrapperDispose(Boolean))
Public method DowngradeOpen Downgrades this object from ForWrite to ForRead.
Public method DowngradeToNotify Downgrades this object from ForNotify and ForWrite to having just one open mode - ForNotify. Currently not implemented.
Public method DwgIn Reads the .dwg file format data of this object from the specified file.
Protected method DwgInFields  
Public method DwgOut Writes the .dwg file format data of this object to the specified filer.
Protected method DwgOutFields  
Public method DxfIn Reads the .dxf file format data of this object from the specified file.
Protected method DxfInFields  
Public method DxfOut Writes the .dxf file format data of this object to the specified filer.
Protected method DxfOutFields  
Public method Erase Marks this object as "erased".
Public method Erase(Boolean) Sets the erased mode of this object.
Public methodStatic member FromAcadObject Returns the ID of an ACAD database object.
Public method GetEventExtender  
Public method GetField Returns the object ID of a "TEXT" field object from the field dictionary.
Public method GetField(String) Returns the object ID of the specified field object (that matches the property name) from the field dictionary.
Public method GetObjectSaveVersion(DwgFiler) Returns the drawing and maintenance release version into which this object must be stored.
Public method GetObjectSaveVersion(DxfFiler) Returns the drawing and maintenance release version into which this object must be stored.
Public method GetPersistentReactorIds Returns the object IDs of this object's persistent reactors.
Public method GetReactors Obsolete.
Returns this object's transient reactors.
Public method GetTransientReactors Returns this object's transient reactors.
Public method GetXDataForApplication Returns a linked list of ResBufs containing a copy of the XData of this object.
Public method HandOverTo Replaces this database-resident (DBRO) object with the specified non-database-resident (NDBRO) object, while retaining this object's objectId, handle, owner, and reactor list.
Public method HasContext Checks whether the specified context exists in the collection.
Public method HasPersistentReactor Checks whether the passed identifier is an identifier of a reactor attached to this object.
Public methodStatic member IsCustomObject Checks whether the passed ID relates to a custom object. Currently not implemented.
Public method ReleaseExtensionDictionary Releases and erases this object's extension dictionary if it exists and is empty.
Public method RemoveContext Removes a context from the collection. An active context can't be removed.
Public method RemoveField Removes the text field and returns its field ID.
Public method RemoveField(ObjectId) Removes the specified field.
Public method RemoveField(String) Removes the specified field by its name and returns its ID.
Public method RemovePersistentReactor Removes the specified persistent reactor from this object's reactor list.
Public method ResetScaleDependentProperties Resets object properties that depend on scale to the default values.
Public method SetField(Field) Sets the specified field for the "TEXT" property.
Public method SetField(String, Field) Sets the specified field for the specified property.
Public method SetFromStyle Sets the annotative property of an object according to its corresponding style, such as styles of text objects.
Public method SetObjectIdsInFlux Called on a newly created cloned object to indicate that its object ID is not valid.
Public method SetPaperOrientation Sets the paper orientation property of a specified object.
Protected method SubSetAttributes
(Overrides DrawableSubSetAttributes(DrawableTraits))
Protected method SubViewportDraw
(Overrides DrawableSubViewportDraw(ViewportDraw))
Protected method SubViewportDrawLogicalFlags
(Overrides DrawableSubViewportDrawLogicalFlags(ViewportDraw))
Protected method SubWorldDraw
(Overrides DrawableSubWorldDraw(WorldDraw))
Public method SupportsCollection Checks whether a particular context type is supported by this object. This method shows whether an object supports a collection type but does not show whether this object participates in any contexts of that type.
Public method SwapIdWith Swaps the objectIDs, handles, extended data (XData), and extension dictionary between this object and another object.
Public method SwapReferences This method performs object ID reference translations similar to those done at the end of deep cloning. References between objects in the workset have their object identifiers translated to the swapped object identifiers of the referenced objects. In contrast to cloning, this translation must occur in both directions. Accordingly, it is possible to pass two different ID maps in two different calls to this method. Currently not implemented.
Public method UpgradeFromNotify Upgrades the object from at least ForNotify mode to both ForNotify and ForWrite modes. You should place a call to DowngradeToNotify() with no Open() or Close() methods in between. For internal use. Currently not implemented.
Public method UpgradeOpen  
Public method WblockClone Performs a shallow clone of this object.
Public method XDataTransformBy Applies the 3D transformation matrix to the XData of this object.
Top
Events
  Name Description
Public event Cancelled  
Public event Copied Notification event called whenever the notifying object has had its clone() member function called.
Public event Erased Notification event called whenever an object has been erased or unerased.
Public event Goodbye Notification event called just before an object is deleted from memory.
Public event Modified Notification event called whenever an object is opened ForWrite, a function has been called that could modify the content of this object, and this object is now being closed.
Public event ModifiedXData Notification event called whenever the XData has been written to the notifying object.
Public event ModifyUndone Notification event called whenever the notifying object is currently performing an undo operation that is undoing modifications.
Public event ObjectClosed Notification event called immediately before an object is closed.
Public event OpenedForModify Notification event called whenever an object is opened for modifying ForWrite.
Public event Reappended Notification event called whenever a redo process processes the reappending of the notifying object to the database.
Public event SubObjectModified  
Public event Unappended Notification event called whenever the undo process processes the appending of the notifying object to the database.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Bricscad.CivilCivilObjectBase
            Teigha.Aec.DatabaseServicesDBObject
            Teigha.DatabaseServicesAssocAction
            Teigha.DatabaseServicesAssocDependency
            Teigha.DatabaseServicesAssocManager
            Teigha.DatabaseServicesBackground
            Teigha.DatabaseServicesBlockPropertiesTable
            Teigha.DatabaseServicesDataLink
            Teigha.DatabaseServicesDataTable
            Teigha.DatabaseServicesDBDictionary
            Teigha.DatabaseServicesDBVisualStyle
            Teigha.DatabaseServicesDimAssoc
            Teigha.DatabaseServicesDrawOrderTable
            Teigha.DatabaseServicesEntity
            Teigha.DatabaseServicesField
            Teigha.DatabaseServices.FiltersFilter
            Teigha.DatabaseServices.FiltersIndex
            Teigha.DatabaseServicesGeoLocationData
            Teigha.DatabaseServicesGroup
            Teigha.DatabaseServicesLinkedData
            Teigha.DatabaseServicesMaterial
            Teigha.DatabaseServicesMLeaderStyle
            Teigha.DatabaseServicesMlineStyle
            Teigha.DatabaseServicesPlaceHolder
            Teigha.DatabaseServicesPlotSettings
            Teigha.DatabaseServicesProxyObject
            Teigha.DatabaseServicesRasterImageDef
            Teigha.DatabaseServicesRasterVariables
            Teigha.DatabaseServicesRenderEnvironment
            Teigha.DatabaseServicesRenderGlobal
            Teigha.DatabaseServicesRenderSettings
            Teigha.DatabaseServicesSectionManager
            Teigha.DatabaseServicesSectionSettings
            Teigha.DatabaseServicesSun
            Teigha.DatabaseServicesSymbolTable
            Teigha.DatabaseServicesSymbolTableRecord
            Teigha.DatabaseServicesTableStyle
            Teigha.DatabaseServicesUnderlayDefinition
            Teigha.DatabaseServicesXrecord
            Teigha.Internal.DatabaseServicesEvalGraph

©  Bricsys NV. All rights reserved.