Rotates this entity by the specified angle
about the axis defined by the point and the vector.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void RotateBy(
double angle,
Vector3d vector,
Point3d point
)
Public Sub RotateBy (
angle As Double,
vector As Vector3d,
point As Point3d
)
public:
void RotateBy(
double angle,
Vector3d vector,
Point3d point
)
member RotateBy :
angle : float *
vector : Vector3d *
point : Point3d -> unit
Parameters
- angle Double
- [in] Rotation angle.
- vector Vector3d
- [in] Vector about which the entitiy is rotated.
- point Point3d
- [in] Basepoint.
See Also