DatabaseWblock(ObjectId) Method
|
Clones the specified block table record of
this database to a new database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Database Wblock(
ObjectId blockId
)
Public Function Wblock (
blockId As ObjectId
) As Database
public:
Database^ Wblock(
ObjectId blockId
)
member Wblock :
blockId : ObjectId -> Database
Parameters
- blockId ObjectId
- [in] Identifier of the block table record to be cloned.
Return Value
Database
A handle to the cloned database.
Remarks
All objects are
cloned with their dependencies. For example, if a text entity uses
a specific textstyle, it will be copied as well.
See Also