NurbSurfaceGetNormal
Method
|
Returns the normal vector at the specified
parameter location ([u, v]).
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Vector3d GetNormal(
double dU,
double dV
)
Public Function GetNormal (
dU As Double,
dV As Double
) As Vector3d
public:
Vector3d GetNormal(
double dU,
double dV
)
member GetNormal :
dU : float *
dV : float -> Vector3d
Parameters
- dU Double
- [in] U parameter.
- dV Double
- [in] V parameter.
Return Value
Vector3d
Remarks
If the surface
doesn't contain control point information, the method throws the
eFail exception. The method throws the
eOutOfRange exception if dU or dV are not
valid.
See Also