PolylineAddVertexAt Method
|
Inserts a vertex to this polyline entity at
the specified index.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void AddVertexAt(
int index,
Point2d pt,
double bulge,
double startWidth,
double endWidth
)
Public Sub AddVertexAt (
index As Integer,
pt As Point2d,
bulge As Double,
startWidth As Double,
endWidth As Double
)
public:
void AddVertexAt(
int index,
Point2d pt,
double bulge,
double startWidth,
double endWidth
)
member AddVertexAt :
index : int *
pt : Point2d *
bulge : float *
startWidth : float *
endWidth : float -> unit
Parameters
- index Int32
- [in] Vertex index.
- pt Point2d
- [in] OCS point of the vertex.
- bulge Double
- [in] Bulge value for the segment following the vertex.
- startWidth Double
- [in] Start width for the segment following the vertex.
- endWidth Double
- [in] End width for the segment following the vertex.
See Also