NurbCurve3dAddControlPointAt
Method
|
Adds a control point at the specified
knot.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void AddControlPointAt(
double newKnot,
Point3d point,
double weight
)
Public Sub AddControlPointAt (
newKnot As Double,
point As Point3d,
weight As Double
)
public:
void AddControlPointAt(
double newKnot,
Point3d point,
double weight
)
member AddControlPointAt :
newKnot : float *
point : Point3d *
weight : float -> unit
Parameters
- newKnot Double
- [in] The knot parameter to add the control point at.
- point Point3d
- [in] Coordinates of the control point to be added.
- weight Double
- [in] The weight to be assigned to the control point.
See Also