SymbolUtilityServicesRepairPreExtendedSymbolName
Method
|
Retrieves a string that is the result of
"repairing" the passed string. The method calls the
validatePreExtendedSymbolname() and validateSymbolName() methods to
properly repair the passed string. As a result, the returned string
contains only valid characters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static string RepairPreExtendedSymbolName(
string oldName,
bool allowVerticalBar
)
Public Shared Function RepairPreExtendedSymbolName (
oldName As String,
allowVerticalBar As Boolean
) As String
public:
static String^ RepairPreExtendedSymbolName(
String^ oldName,
bool allowVerticalBar
)
static member RepairPreExtendedSymbolName :
oldName : string *
allowVerticalBar : bool -> string
Parameters
- oldName String
- [in] Name to repair.
- allowVerticalBar Boolean
- [in] Flag that specifies whether vertical bars ("|") are
allowed in the symbol name.
Return Value
String
The repaired symbol name.
See Also