SymbolUtilityServices Class

This .NET class contains various utilities for working with symbol names, symbol records, and symbol tables.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesSymbolUtilityServices

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class SymbolUtilityServices

The SymbolUtilityServices type exposes the following members.

Constructors
  Name Description
Public method SymbolUtilityServices Initializes a new instance of the SymbolUtilityServices class
Top
Properties
  Name Description
Public propertyStatic member BlockModelSpaceName Property that represents the predefined symbol record of the model space name. Cannot be NULL or an empty string.
Public propertyStatic member BlockPaperSpaceName Property that represents the predefined symbol record of a paper space name. Cannot be NULL or an empty string.
Public propertyStatic member LayerDefpointsName Property that represents the predefined symbol record of a Defpoints layer name. Cannot be NULL or an empty string.
Public propertyStatic member LayerZeroName Property that represents the predefined symbol record of the 0 layer name. Cannot be NULL or an empty string.
Public propertyStatic member LinetypeByBlockName Property that represents the predefined symbol record of the ByBlock linetype name. Cannot be NULL or an empty string.
Public propertyStatic member LinetypeByLayerName Property that represents the predefined symbol record of the ByLayer linetype name. Cannot be NULL or an empty string.
Public propertyStatic member LinetypeContinuousName Property that represents the predefined symbol record of the Continuous linetype name. Cannot be NULL or an empty string.
Public propertyStatic member RegAppAcadName Property that represents the predefined symbol record of a registered application name. Cannot be NULL or an empty string.
Public propertyStatic member TextStyleStandardName Property that represents the predefined symbol record of the Standard text style name. Cannot be NULL or an empty string.
Public propertyStatic member ViewportActiveName Property that represents the predefined symbol record of the active viewport name. Cannot be NULL or an empty string.
Top
Methods
  Name Description
Public methodStatic member GetBlockModelSpaceId Retrieves the model space identifier of the predefined symbol table record for the specified database.
Public methodStatic member GetBlockNameFromInsertPathName Retrieves the block name from a specified path name.
Public methodStatic member GetBlockPaperSpaceId Retrieves the identifier of the predefined symbol table record for the specified database.
Public methodStatic member GetInsertPathNameFromBlockName Retrieves the path name of the specified block name. If the retrieved path name does not have an extension, ".dwg" is appended to the end of the string.
Public methodStatic member GetLayerDefpointsId Retrieves the identifier of the "DEFPOINTS" layer object of the specified database.
Public methodStatic member GetLayerZeroId Retrieves the identifier of the "0" layer object of the specified database.
Public methodStatic member GetLinetypeByBlockId Retrieves the identifier of the "ByBlock" linetype object of the specified database.
Public methodStatic member GetLinetypeByLayerId Retrieves the identifier of the "ByLayer" linetype object of the specified database.
Public methodStatic member GetLinetypeContinuousId Retrieves the identifier of the "Continuous" linetype object of the specified database.
Public methodStatic member GetMaxSymbolNameLength Retrieves the maximum allowed length for symbol names.
Public methodStatic member GetPathNameFromSymbolName Retrieves the path name from a specified block name and extension(s). The string extension is appended to the end of the string if the retrieved string does not have an extension.
Public methodStatic member GetRegAppAcadId Retrieves the identifier of the "ACAD" RegApp object of the specified database object.
Public methodStatic member GetSymbolNameFromPathName Retrieves a suitable symbol name from a path name. The symbol name represents the filename component of the path. Any of the specified filename extensions are removed. If an invalid pathName is provided, the symbol name can also be invalid.
Public methodStatic member GetTextStyleStandardId Retrieves an identifier of a standard text style.
Public methodStatic member IsBlockLayoutName Checks whether the passed name is a layout's block-table record name or the name of the main paper space block. The string is normalized before comparing it with the predefined name.
Public methodStatic member IsBlockModelSpaceName Checks whether the passed name matches the model space name. The string is normalized before comparing it with the predefined name.
Public methodStatic member IsBlockPaperSpaceName Checks whether the passed name matches a paper space name. The string is normalized before comparing with the predefined name.
Public methodStatic member IsCompatibilityMode Checks the EXTNAMES setting for the specified database.
Public methodStatic member IsLayerDefpointsName Checks whether the passed string matches the "Defpoints" layer name.
Public methodStatic member IsLayerZeroName Checks whether the passed string matches the "0" layer name.
Public methodStatic member IsLinetypeByBlockName Checks whether the passed string matches the "ByBlock" linetype name.
Public methodStatic member IsLinetypeByLayerName Checks whether the passed string matches the "ByLayer" linetype name.
Public methodStatic member IsLinetypeContinuousName Checks whether the passed string matches the "Continuous" linetype name.
Public methodStatic member IsRegAppAcadName Checks whether the passed string matches the name of the "ACAD" RegApp object.
Public methodStatic member IsTextStyleStandardName Checks whether the passed string matches the "Standard" linetype name.
Public methodStatic member IsViewportActiveName Checks whether the passed string matches the viewport active name "*Active".
Public methodStatic member MakeDependentName Combines the specified drawing name and symbol name to create a dependent symbol name.
Public methodStatic member PreValidateSymbolName Executes pre-validation measures on a string that will later be validated as a symbol name.
Public methodStatic member RepairPreExtendedSymbolName Retrieves a string that is the result of "repairing" the passed string. The method calls the validatePreExtendedSymbolname() and validateSymbolName() methods to properly repair the passed string. As a result, the returned string contains only valid characters.
Public methodStatic member RepairSymbolName Retrieves a string that is the result of "repairing" the passed string. The method calls the validatePreExtendedSymbolname() and validateSymbolName() methods to properly repair the passed string. As a result, the returned string contains only valid characters.
Public methodStatic member ValidateCompatibleSymbolName Validates a symbol name and checks whether its length is acceptable.
Public methodStatic member ValidatePreExtendedSymbolName Validates a name for legacy symbol names.
Public methodStatic member ValidateSymbolName Validates a name for extended symbol names.
Top
See Also

©  Bricsys NV. All rights reserved.