NurbSurfaceInsertControlPointsAtV
Method
|
Inserts a row of control points at the
specified v-knot parameter.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertControlPointsAtV(
double dV,
Point3dCollection uCtrlPts,
DoubleCollection uWeights
)
Public Sub InsertControlPointsAtV (
dV As Double,
uCtrlPts As Point3dCollection,
uWeights As DoubleCollection
)
public:
void InsertControlPointsAtV(
double dV,
Point3dCollection^ uCtrlPts,
DoubleCollection^ uWeights
)
member InsertControlPointsAtV :
dV : float *
uCtrlPts : Point3dCollection *
uWeights : DoubleCollection -> unit
Parameters
- dV Double
- [in] V parameter.
- uCtrlPts Point3dCollection
-
- uWeights DoubleCollection
-
Remarks
If the surface
doesn't contain any NURBS information, the method throws the
eFail exception. If the dV parameter is out of range, throws the eOutOfRange exception.
See Also