ExtrudedSurfaceSetExtrude
Method
|
Sets data that defines the parameters of an
extruded surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetExtrude(
Vector3d sweepVec,
SweepOptions sweepOptions
)
Public Sub SetExtrude (
sweepVec As Vector3d,
sweepOptions As SweepOptions
)
public:
void SetExtrude(
Vector3d sweepVec,
SweepOptions^ sweepOptions
)
member SetExtrude :
sweepVec : Vector3d *
sweepOptions : SweepOptions -> unit
Parameters
- sweepVec Vector3d
- [in] A new extrusion vector.
- sweepOptions SweepOptions
- [in] Sweep options.
Remarks
Additional
extruding parameters (for example, draft angle) can be specified
with the sweepOptions object. This method
is implemented only for Spatial modeler and throws the eNotImplementedYet exception for other
modelers.
See Also