Curve2dGetClosestPointTo(Curve2d)
Method
|
Retrieves the closest points between this
curve and the passed curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve2d[] GetClosestPointTo(
Curve2d curve
)
Public Function GetClosestPointTo (
curve As Curve2d
) As PointOnCurve2d()
public:
array<PointOnCurve2d^>^ GetClosestPointTo(
Curve2d^ curve
)
member GetClosestPointTo :
curve : Curve2d -> PointOnCurve2d[]
Parameters
- curve Curve2d
- [in] Curve to which closest points are calculated.
Return Value
PointOnCurve2d
Array of closest points. The point with index 0 is the closest
point on this curve; the point with index 1 is the closest point on
the other curve.
See Also