CylinderIntersectWith(LinearEntity3d) Method

Calculates intersection points with the specified linear entity.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Point3d[] IntersectWith(
        LinearEntity3d linearEntity
)

Parameters

linearEntity  LinearEntity3d
[in] Linear entity with which to calculate intersections.

Return Value

Point3d
If the method fails or there are no intersection points, this method returns nullptr. The returned array consists of two elements. The first element corresponds to the first intersection point (if it exists), and the second element corresponds to the second intersection point (if it exists).
See Also

©  Bricsys NV. All rights reserved.