LinearEntity3d Class

This class is the base class for 3D linear entities. For more information, see Working with Lines.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometryLinearEntity3d
            Teigha.GeometryLine3d
            Teigha.GeometryLineSegment3d
            Teigha.GeometryRay3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class LinearEntity3d : Curve3d

The LinearEntity3d type exposes the following members.

Properties
  Name Description
Public property Direction  
Public property PointOnLine  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetLine Returns an infinite line that is colinear with this linear entity.
Public method GetPerpendicularPlane Returns a plane that is perpendicular to this linear entity at the specified point.
Public method IntersectWith(LinearEntity3d) Calculates an intersection point with the specified line.
Public method IntersectWith(PlanarEntity) Calculates an intersection point with the specified plane.
Public method IntersectWith(LinearEntity3d, Tolerance) Calculates an intersection point with the specified line according to a geometry tolerance.
Public method IntersectWith(PlanarEntity, Tolerance) Calculates an intersection point with the specified plane according to a geometry tolerance.
Public method IsColinearTo(LinearEntity3d) Checks whether the specified line is colinear to this linear entity.
Public method IsColinearTo(LinearEntity3d, Tolerance) Checks whether the specified line is colinear to this linear entity according to a tolerance.
Public method IsOn(Plane) Checks whether this linear entity lies on the specified plane.
Public method IsOn(Plane, Tolerance) Checks whether this linear entity lies on the specified plane according to a tolerance.
Public method IsParallelTo(LinearEntity3d) Checks whether the specified line is parallel to this linear entity.
Public method IsParallelTo(PlanarEntity) Checks whether the specified plane is parallel to this linear entity.
Public method IsParallelTo(LinearEntity3d, Tolerance) Checks whether the specified line is parallel to this linear entity according to a tolerance.
Public method IsParallelTo(PlanarEntity, Tolerance) Checks whether the specified plane is parallel to this linear entity according to a tolerance.
Public method IsPerpendicularTo(LinearEntity3d) Checks whether the specified line is perpendicular to this linear entity.
Public method IsPerpendicularTo(PlanarEntity) Checks whether the specified plane is perpendicular to this linear entity.
Public method IsPerpendicularTo(LinearEntity3d, Tolerance) Checks whether the specified line is perpendicular to this linear entity according to a tolerance.
Public method IsPerpendicularTo(PlanarEntity, Tolerance) Checks whether the specified plane is perpendicular to this linear entity according to a tolerance.
Public method Overlap(LinearEntity3d) Calculates and returns the overlap of this linear entity and the specified line.
Public method Overlap(LinearEntity3d, Tolerance) Calculates and returns the overlap of this linear entity and the specified line according to a tolerance.
Public method ProjectedIntersectWith(LinearEntity3d, Vector3d) Calculates the projected intersection of the specified line with this linear entity.
Public method ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) Calculates the projected intersection of the specified line with this linear entity according to a tolerance.
Top
See Also

©  Bricsys NV. All rights reserved.