Vertex2d(Point3d, Double, Double, Double, Double)
Constructor
|
Constructor for the Vertex2d class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Vertex2d(
Point3d position,
double bulge,
double startWidth,
double endWidth,
double tangent
)
Public Sub New (
position As Point3d,
bulge As Double,
startWidth As Double,
endWidth As Double,
tangent As Double
)
public:
Vertex2d(
Point3d position,
double bulge,
double startWidth,
double endWidth,
double tangent
)
new :
position : Point3d *
bulge : float *
startWidth : float *
endWidth : float *
tangent : float -> Vertex2d
Parameters
- position Point3d
- [in] OCS position point.
- bulge Double
- [in] Bulge of the segment following this vertex.
- startWidth Double
- [in] Starting width of the segment following this vertex.
- endWidth Double
- [in] Ending width of the segment following this vertex.
- tangent Double
- [in] Curve fit tangent direction for this vertex.
See Also