SurfaceBooleanIntersect(Surface) Method
|
Performs a Boolean intersection operation
between this surface and the specified surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Entity[] BooleanIntersect(
Surface surface2
)
Public Overridable Function BooleanIntersect (
surface2 As Surface
) As Entity()
public:
virtual array<Entity^>^ BooleanIntersect(
Surface^ surface2
)
abstract BooleanIntersect :
surface2 : Surface -> Entity[]
override BooleanIntersect :
surface2 : Surface -> Entity[]
Parameters
- surface2 Surface
- [in] Other surface to be intersected with the surface.
Return Value
Entity
Entities representing the intersections between two surfaces.
Remarks
This method is
implemented only for the ModelerGeometry and Spatial modelers. If
the intersection of the surface and the solid is not a surface, all
intersection curves and points are stored in the returned array and
this surface is not changed. If the intersection of the surface and
the solid is a surface, no intersection curves or points are
retrieved. If this surface is not derived from the Surface class,
the resulting surface is stored in this surface. Otherwise, this
surface is not changed and the result is stored in
intersectionEntities. If the surfaces don't intersect, the method
throws the eNoIntersections exception, and this surface is not
changed. If the intersection operation fails, this surface is not
changed.
See Also