NurbSurfaceGetParameterOfPoint
Method
|
Returns the u and v parameter for a point on
the surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void GetParameterOfPoint(
Point3d point,
out double dU,
out double dV
)
Public Sub GetParameterOfPoint (
point As Point3d,
<OutAttribute> ByRef dU As Double,
<OutAttribute> ByRef dV As Double
)
public:
void GetParameterOfPoint(
Point3d point,
[OutAttribute] double% dU,
[OutAttribute] double% dV
)
member GetParameterOfPoint :
point : Point3d *
dU : float byref *
dV : float byref -> unit
Parameters
- point Point3d
- [in] A point on the surface.
- dU Double
- [out] Receives the u parameter.
- dV Double
- [out] Receives the v parameter.
Remarks
If the surface
doesn't contain the control point information, the method throws
the eFail exception. If this method is
not implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also