LinkedTableDataGetCellState Method
|
Returns the state of the cell.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual CellStates GetCellState(
int row,
int column
)
Public Overridable Function GetCellState (
row As Integer,
column As Integer
) As CellStates
public:
virtual CellStates GetCellState(
int row,
int column
)
abstract GetCellState :
row : int *
column : int -> CellStates
override GetCellState :
row : int *
column : int -> CellStates
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
Return Value
CellStates
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. The cell state can be one of the
following values: NameValueNone 0x00 ContentLocked 0x01 ContentReadOnly
0x02 Linked 0x04 ContentModifiedAfterUpdate 0x08 FormatLocked 0x10
FormatReadOnly 0x20 FormatModifiedAfterUpdate 0x40
See Also