Solid3dOffsetFaces
Method
|
Offsets the specified faces of the solid to
the specified distance.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void OffsetFaces(
SubentityId[] subentityIds,
double offsetDistance
)
Public Overridable Sub OffsetFaces (
subentityIds As SubentityId(),
offsetDistance As Double
)
public:
virtual void OffsetFaces(
array<SubentityId>^ subentityIds,
double offsetDistance
)
abstract OffsetFaces :
subentityIds : SubentityId[] *
offsetDistance : float -> unit
override OffsetFaces :
subentityIds : SubentityId[] *
offsetDistance : float -> unit
Parameters
- subentityIds SubentityId
- [in] Face's subentity ID in the solid.
- offsetDistance Double
- [in] Offset distance.
Remarks
Faces with
surfaces that cannot be offset are removed and the solid is healed,
if possible. The following constraints are applied: * Number of
specified faces (in the subentityIds parameter) must be more than
zero. * offsetDistance >= minus half of the maximum side of the
solid's bounding box. * |offsetDistance| >= 1e-6. This method is
implemented only for the Spatial modeler.
See Also