Solid3dExtrudeFacesAlongPath
Method
|
Extrudes the specified faces along the
specified path determined by a curve entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void ExtrudeFacesAlongPath(
SubentityId[] subentityIds,
Curve path
)
Public Overridable Sub ExtrudeFacesAlongPath (
subentityIds As SubentityId(),
path As Curve
)
public:
virtual void ExtrudeFacesAlongPath(
array<SubentityId>^ subentityIds,
Curve^ path
)
abstract ExtrudeFacesAlongPath :
subentityIds : SubentityId[] *
path : Curve -> unit
override ExtrudeFacesAlongPath :
subentityIds : SubentityId[] *
path : Curve -> unit
Parameters
- subentityIds SubentityId
- [in] Face's subentity ID in the solid.
- path Curve
- [in] Curve object to extrude along (extrusion path).
Remarks
Faces for
extrusion must be planar. The path entity must be one of the
following: * Line * Arc * Ellipse * Spline * 2D polyline *
Non-spline fit 3D polyline The wxtrusion path must not have
self-intersections. Also it is recommended that the path doesn't
have high curvature areas. If one of the end points of the path is
not located on the region's plane, the path moves the point on the
plane. This method is implemented only for the Spatial
modeler.
See Also