EllipticalArc3dSet(Point3d,
Vector3d, Vector3d, Double, Double) Method
|
Sets the specified center, axes and radii for
this arc.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius
)
Public Sub Set (
center As Point3d,
majorAxis As Vector3d,
minorAxis As Vector3d,
majorRadius As Double,
minorRadius As Double
)
public:
void Set(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius
)
member Set :
center : Point3d *
majorAxis : Vector3d *
minorAxis : Vector3d *
majorRadius : float *
minorRadius : float -> unit
Parameters
- center Point3d
- [in] Center of this arc.
- majorAxis Vector3d
- [in] Vector that defines the major axis of this arc.
- minorAxis Vector3d
- [in] Vector that defines the minor axis of this arc.
- majorRadius Double
- [in] A point on the axis of symmetry.
- minorRadius Double
- [in] Axis of symmetry (rotation).
See Also