DBObjectSwapIdWith Method
|
Swaps the objectIDs, handles, extended data
(XData), and extension dictionary between this object and another
object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SwapIdWith(
ObjectId otherId,
bool swapExtendedData,
bool swapExtensionDictionary
)
Public Sub SwapIdWith (
otherId As ObjectId,
swapExtendedData As Boolean,
swapExtensionDictionary As Boolean
)
public:
void SwapIdWith(
ObjectId otherId,
bool swapExtendedData,
bool swapExtensionDictionary
)
member SwapIdWith :
otherId : ObjectId *
swapExtendedData : bool *
swapExtensionDictionary : bool -> unit
Parameters
- otherId ObjectId
- [in] Object ID of object with which to swap.
- swapExtendedData Boolean
- [in] Flag specifying whether to swap extended data
(XData).
- swapExtensionDictionary Boolean
- [in] Flag specifying whether to swap the extension
dictionary.
See Also