AssocEvaluationCallbackBeginActionEvaluationUsingObject
Method
|
Initiates action evaluation. The action
informs that it will perform read and write operations on the
object represented by objectId. The
action uses this callback just before it opens the object for read
or write. Currently not implemented.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public abstract void BeginActionEvaluationUsingObject(
AssocAction pAction,
ObjectId objectId,
bool objectIsGoingToBeUsed,
bool objectIsGoingToBeModified,
DBObject substituteObject
)
Public MustOverride Sub BeginActionEvaluationUsingObject (
pAction As AssocAction,
objectId As ObjectId,
objectIsGoingToBeUsed As Boolean,
objectIsGoingToBeModified As Boolean,
substituteObject As DBObject
)
public:
virtual void BeginActionEvaluationUsingObject(
AssocAction^ pAction,
ObjectId objectId,
bool objectIsGoingToBeUsed,
bool objectIsGoingToBeModified,
DBObject^ substituteObject
) abstract
abstract BeginActionEvaluationUsingObject :
pAction : AssocAction *
objectId : ObjectId *
objectIsGoingToBeUsed : bool *
objectIsGoingToBeModified : bool *
substituteObject : DBObject -> unit
Parameters
- pAction AssocAction
- [in] The action to be evaluated.
- objectId ObjectId
- [in] The object identifier that is going to be used or modified
by the action.
- objectIsGoingToBeUsed Boolean
- [in] A flag that specifies whether object content should be
used.
- objectIsGoingToBeModified Boolean
- [in] A flag that specifies whether object content should be
modified.
- substituteObject DBObject
- [out] An object that is optionally provided by the client code.
The client code does not have to assign a value to this output
argument.
See Also