CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d) Constructor

Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with the passed start and end derivatives, and fit points.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public CubicSplineCurve2d(
        Point2dCollection fitPoints,
        Vector2d startDerivative,
        Vector2d endDerivative
)

Parameters

fitPoints  Point2dCollection
[in] Array of fit points.
startDerivative  Vector2d
[in] Starting derivative of the cubic spline curve.
endDerivative  Vector2d
[in] Ending derivative of the cubic spline curve.
See Also

©  Bricsys NV. All rights reserved.