Vector2d Structure

This .NET class wraps the OdGeVector2d class. This class represents vectors in 2D space. Vector2d may be viewed as an array[2] of doubles. For more information, see Working with Basic Geometry Types.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryVector2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Vector2d : IFormattable

The Vector2d type exposes the following members.

Constructors
  Name Description
Public method Vector2d(Double) Constructor for the Vector2d class. Creates a new vector with coordinates taken from the first two values of the passed array.
Public method Vector2d(Double, Double) Constructor for the Vector2d class. Creates a new vector with coordinates specified by the x and y values.
Top
Properties
  Name Description
Public property Angle  
Public property Coordinate  
Public property Length  
Public property LengthSqrd  
Public property X  
Public propertyStatic member XAxis  
Public property Y  
Public propertyStatic member YAxis  
Top
Methods
  Name Description
Public method Add Adds this vector to the specified vector.
Public method DivideBy Divides this vector by the passed value.
Public method DotProduct Returns the dot product of this vector and the specified vector.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetAngleTo Retrieves the angle between this vector and the passed vector.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetNormal Retrieves the unit vector co-directional to this vector.
Public method GetNormal(Tolerance) Retrieves the unit vector co-directional to this vector with respect to a geometric tolerance.
Public method GetPerpendicularVector Retrieves a vector orthogonal to this vector with ( -y, x) coordinates.
Public method IsCodirectionalTo(Vector2d) Checks whether the passed vector is co-directional to this vector.
Public method IsCodirectionalTo(Vector2d, Tolerance) Checks whether the passed vector is co-directional to this vector with respect to a geometric tolerance.
Public method IsEqualTo(Vector2d) Checks whether the passed vector is equal to this vector. Vectors are considered equal if all coordinates of this vector are the same as coordinates of the specified vector.
Public method IsEqualTo(Vector2d, Tolerance) Checks whether the passed vector is equal to this vector. Vectors are considered equal if all coordinates of this vector are the same as coordinates of the specified vector within geometric tolerance.
Public method IsParallelTo(Vector2d) Checks whether the passed vector is parallel to this vector.
Public method IsParallelTo(Vector2d, Tolerance) Checks whether the passed vector is parallel to this vector with respect to a geometric tolerance.
Public method IsPerpendicularTo(Vector2d) Checks whether the passed vector is perpendicular to this vector.
Public method IsPerpendicularTo(Vector2d, Tolerance) Checks whether the passed vector is perpendicular to this vector with respect to a geometric tolerance.
Public method IsUnitLength Checks whether the length of this vector is 1.0.
Public method IsUnitLength(Tolerance) Checks whether the length of this vector is 1.0 with respect to a geometric tolerance.
Public method IsZeroLength Checks whether the length of this vector is 0.0.
Public method IsZeroLength(Tolerance) Checks whether the length of this vector is 0.0 with respect to a geometric tolerance.
Public method Mirror Mirrors this vector about the specified 2D line.
Public method MultiplyBy Multiplies coordinates of this vector by the specified value.
Public method Negate Negates this vector by setting it to be equal to the vector (-x, -y).
Public method RotateBy Rotates vector by the passed angle.
Public method Subtract Subtracts a passed vector from this vector.
Public method ToArray  
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Public method ToString(String, IFormatProvider)  
Public method TransformBy  
Top
Operators
  Name Description
Public operatorStatic member Addition(Vector2d, Vector2d) Addition operator for the Vector2d class.
Public operatorStatic member Division(Vector2d, Double) Division operator for the Vector2d class.
Public operatorStatic member Equality(Vector2d, Vector2d) Equality operator for the Vector2d class.
Public operatorStatic member Inequality(Vector2d, Vector2d) Inequality operator for the Vector2d class.
Public operatorStatic member Multiply(Double, Vector2d) Multiplication operator for the Vector2d class.
Public operatorStatic member Multiply(Matrix2d, Vector2d) Multiplication operator for the Vector2d class.
Public operatorStatic member Multiply(Vector2d, Double) Multiplication operator for the Vector2d class.
Public operatorStatic member Subtraction(Vector2d, Vector2d) Subtraction operator for the Vector2d class.
Public operatorStatic member UnaryNegation(Vector2d) Negation operator for the Vector2d class.
Top
See Also

©  Bricsys NV. All rights reserved.