NurbSurfaceGetControlPointAt
Method
|
Returns the control point (in WCS coordinates)
at the specified position in the control points vector.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d GetControlPointAt(
int uIndex,
int vIndex
)
Public Function GetControlPointAt (
uIndex As Integer,
vIndex As Integer
) As Point3d
public:
Point3d GetControlPointAt(
int uIndex,
int vIndex
)
member GetControlPointAt :
uIndex : int *
vIndex : int -> Point3d
Parameters
- uIndex Int32
- [in] An index of a control point in the u-direction. Index
starts from the 0 value.
- vIndex Int32
- [in] An index of a control point in the v-direction. Index
starts from the 0 value.
Return Value
Point3d
Remarks
If the surface
doesn't contain control point information, the method throws the
eFail exception. The method throws the
eOutOfRange exception if uIndex or vIndex are not
valid.
See Also