LinearEntity2dGetPerpendicularLine Method
|
Returns a 2D line that is perpendicular to
this linear entity and passes through the specified point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Line2d GetPerpendicularLine(
Point2d point
)
Public Function GetPerpendicularLine (
point As Point2d
) As Line2d
public:
Line2d^ GetPerpendicularLine(
Point2d point
)
member GetPerpendicularLine :
point : Point2d -> Line2d
Parameters
- point Point2d
- [in] 2D point through which the perpendicular line passes.
Return Value
Line2d
See Also