LinearEntity2d Class

This class is the base class for 2D linear entities. For more information, see Working with Lines.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometryLinearEntity2d
            Teigha.GeometryLine2d
            Teigha.GeometryLineSegment2d
            Teigha.GeometryRay2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class LinearEntity2d : Curve2d

The LinearEntity2d type exposes the following members.

Properties
  Name Description
Public property Direction  
Public property PointOnLine  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetLine Returns an infinite line colinear with this linear entity.
Public method GetPerpendicularLine Returns a 2D line that is perpendicular to this linear entity and passes through the specified point.
Public method IntersectWith(LinearEntity2d) Calculates an intersection point with the specified line.
Public method IntersectWith(LinearEntity2d, Tolerance) Calculates an intersection point with the specified line according to a geometry tolerance.
Public method IsColinearTo(LinearEntity2d) Checks whether the specified line is colinear to this linear entity.
Public method IsColinearTo(LinearEntity2d, Tolerance) Checks whether the specified line is colinear to this linear entity according to a tolerance.
Public method IsParallelTo(LinearEntity2d) Checks whether the specified line is parallel to this linear entity.
Public method IsParallelTo(LinearEntity2d, Tolerance) Checks whether the specified line is parallel to this linear entity according to tolerance.
Public method IsPerpendicularTo(LinearEntity2d) Checks whether the specified line is perpendicular to this linear entity.
Public method IsPerpendicularTo(LinearEntity2d, Tolerance) Checks whether the specified line is perpendicular to this linear entity according to a tolerance.
Public method Overlap(LinearEntity2d) Calculates and returns the overlap of this linear entity and a specified line.
Public method Overlap(LinearEntity2d, Tolerance) Calculates and returns the overlap of this linear entity and a specified line according to a tolerance.
Top
See Also

©  Bricsys NV. All rights reserved.