QuadReactorappendQuadItems(QuadSelection,
QuadItems) Method
|
Implement appendQuadItems to append QuadItems
to the Quad. This function will be called when the Quad is about to
be shown. Only those QuadItems that have been registered will be
successfully appended. Several reactors may be registered, but only
those which are active (as per settings) will append their items to
the Quad. * This function is called when a Quad is to be shown for
a selection. AcEdQuadSelection can be queried further for hovered
and pickfirst selection data, to make intelligent decisions of
relevant QuadItems to be added to the Quad.
Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version:
24.0.1.0
Syntax
public abstract bool appendQuadItems(
QuadSelection quadSelection,
QuadItems quadItems
)
Public MustOverride Function appendQuadItems (
quadSelection As QuadSelection,
quadItems As QuadItems
) As Boolean
public:
virtual bool appendQuadItems(
QuadSelection^ quadSelection,
QuadItems^ quadItems
) abstract
abstract appendQuadItems :
quadSelection : QuadSelection *
quadItems : QuadItems -> bool
Parameters
- quadSelection QuadSelection
-
- quadItems QuadItems
-
Return Value
Boolean
See Also