QuadSelection Class

This helper class provides access to actual entity selection (picked, hovered), when the Quad is about to be shown - the AcEdQuadReactor::appendQuadItems() provides an instance of this class, to provide the Quad client information about actual selection.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.QuadQuadSelection

Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class QuadSelection : DisposableWrapper

The QuadSelection type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method fullData the full set will contain entities/boundaries from both (pickfirst and hovered) sets; this function is provided to reduce efforts and operations at client side
Public method hasHoveredData the hovered set contains the entity/boundary over which the mouse is just hovering; this entity can also be in the pickfirst set, when it is also (pre-)selected
Public method hasPickFirstData the pickfirst set contains the pre-selected entities/boundaries; this can also contain the hovered entity/boundary, if that is pre-selected
Public method hoveredData the hovered set contains the entity/boundary over which the mouse is just hovering; this entity can also be in the pickfirst set, when it is also (pre-)selected
Public method isValid Returns 'true' if this AcEdQuadSelection is valid; returns 'false' for an empty object, without any (hovered or pickfirst) data
Public method pickFirstData the pickfirst set contains the pre-selected entities/boundaries; this can also contain the hovered entity/boundary, if that is pre-selected
Top
See Also

©  Bricsys NV. All rights reserved.