RevolveOptionsBuilder Class

With this class you can modify the properties of the RevolveOptions class, which is an immutable value type.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesRevolveOptionsBuilder

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class RevolveOptionsBuilder

The RevolveOptionsBuilder type exposes the following members.

Constructors
  Name Description
Public method RevolveOptionsBuilder Default constructor for the RevolveOptionsBuilder class.
Public method RevolveOptionsBuilder(RevolveOptions) Сonstructor for the RevolveOptionsBuilder class. Creates an instance with the specified revolve options.
Top
Properties
  Name Description
Public property CloseToAxis Property that represents the 'close to axis' option. If this option is enabled and an open profile is revolved, the ends of the profile are extended to the axis of revolution before revolving.
Public property DraftAngle Property that represents the draft angle in radians. The profile narrows to this angle as it rotates around the axis.
Public property TwistAngle Property that represents the twist angle in radians. This is the angle by which the profile is twisted as it revolves around the axis.
Top
Methods
  Name Description
Public method ToRevolveOptions Returns the revolve options associated with this instance.
Top
See Also

©  Bricsys NV. All rights reserved.