Curve2dGetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) Method

Retrieves one or more offset curves that represent the trimmed offset of the curve.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Curve2d[] GetTrimmedOffset(
        double distance,
        OffsetCurveExtensionType extensionType,
        Tolerance tolerance
)

Parameters

distance  Double
[in] Offset distance.
extensionType  OffsetCurveExtensionType
[in] Determines how the offset curve will be extended at points of C1 discontinuity.
tolerance  Tolerance
[in] Geometric tolerance.

Return Value

Curve2d
Array that stores offset curves.
See Also

©  Bricsys NV. All rights reserved.