CircularArc3dClosestPointToPlane(PlanarEntity)
Method
|
Retrieves the closest point on this circular
arc and corresponding point on a specified plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ClosestPointToPlane(
PlanarEntity plane
)
Public Function ClosestPointToPlane (
plane As PlanarEntity
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
PlanarEntity^ plane
)
member ClosestPointToPlane :
plane : PlanarEntity -> Point3d[]
Parameters
- plane PlanarEntity
- [in] Plane for which the closest points are calculated.
Return Value
Point3d
Array of closest points.
Remarks
Indices of the
array of retrieved points: 0: Closest point on this circular arc.
1: Closest point on the passed plane.
See Also