SurfaceImprintEntity Method
|
Intersects the specified entity with the
surface and imprints the intersection graph onto the surface. If
creating a closed loop of edges, a new face is created. If creating
an open loop of edges, it can be added as a spur to an existing
loop on a face or as a slit in the face.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void ImprintEntity(
Entity entityToImprint
)
Public Overridable Sub ImprintEntity (
entityToImprint As Entity
)
public:
virtual void ImprintEntity(
Entity^ entityToImprint
)
abstract ImprintEntity :
entityToImprint : Entity -> unit
override ImprintEntity :
entityToImprint : Entity -> unit
Parameters
- entityToImprint Entity
- [in] Entity to be imprinted. Must be one of the following
types: Curve, Solid3d, Surface, Body, Region, Trace, Solid or
Face.
Remarks
This method is
implemented only for the Spatial modeler.
See Also