Curve3dGetSamplePoints(Int32) Method

Retrieves an array of sample points along this curve.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public PointOnCurve3d[] GetSamplePoints(
        int numSample
)

Parameters

numSample  Int32
[in] Quantity of sample points.

Return Value

PointOnCurve3d
Array of sample points.
Remarks
For example, if parametric range of this curve is [0,2] and the numSample is 5, the retrieved points correspond to the following parametric values: 0, 0.5, 1, 1.5, 2.
See Also

©  Bricsys NV. All rights reserved.