Point
|
The PointOnCurve3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
PointOnCurve3d | Default constructor for the PointOnCurve3d class. Creates a default corresponding C++ object with a point that does not lie on any curve and has a parameter value of 0. |
![]() |
PointOnCurve3d(Curve3d, Double) | Constructor for the PointOnCurve3d class. Creates a point on the specified curve with the provided parameter value. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Curve | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
Parameter | |
![]() |
Point | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | Clones this entity and returns a handle to the cloned
entity. (Inherited from Entity3d) |
![]() ![]() |
Create | Creates an object based on the passed pointer and returns a handle to the created object. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
GetCurvature | Calculates the curvature of the curve at this point on the curve. Currently not implemented. |
![]() |
GetCurvature(Double) | Calculates the curvature of the curve at the point that corresponds to the specified parameter value. Currently not implemented. |
![]() |
GetDerivative(Int32) | Returns the derivative of the curve at the point on the curve. |
![]() |
GetDerivative(Int32, Double) | Returns the derivative of the curve at the point on the curve. |
![]() ![]() |
GetDerivative(Int32, Curve3d, Double) | Returns the derivative of the curve at the point on the curve. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetPoint | Returns a point. (Inherited from PointEntity3d) |
![]() |
GetPointAtParameter | Resets the parameter on a curve and returns a point that corresponds to that parameter. |
![]() ![]() |
GetPointOnCurve | Sets the parameter on the specified curve and returns a point that corresponds to that parameter. |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
IsEqualTo(Entity3d) | Checks whether this entity is equal to the specified
entity. (Inherited from Entity3d) |
![]() |
IsEqualTo(Entity3d, Tolerance) | Checks whether this entity is equal to the specified entity
within a geometric tolerance. (Inherited from Entity3d) |
![]() |
IsOn(Point3d) | Checks whether the specified point is on this entity. (Inherited from Entity3d) |
![]() |
IsOn(Point3d, Tolerance) | Checks whether the specified point is on this entity according
to a geometric tolerance. (Inherited from Entity3d) |
![]() |
IsSingular | Checks whether the first derivative vector has zero length. |
![]() |
IsSingular(Tolerance) | Checks whether the first derivative vector has zero length according to a tolerance. |
![]() |
Mirror | Mirrors this entity about the specified plane. (Inherited from Entity3d) |
![]() |
RotateBy | Rotates this entity by the specified angle about the axis
defined by the point and the vector. (Inherited from Entity3d) |
![]() |
ScaleBy | Scales this entity by the scale factor about the specified
point. (Inherited from Entity3d) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TransformBy | Applies the specified 2D transformation matrix to this
entity. (Inherited from Entity3d) |
![]() |
TranslateBy | Translates this entity by applying a 3D translation
vector. (Inherited from Entity3d) |
© Bricsys NV. All rights reserved. |