SurfaceCreateOffsetSurface(Entity,
Double, Boolean) Method
|
Creates an offset surface and includes it in
the current database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static ObjectId CreateOffsetSurface(
Entity entity,
double offsetDistance,
bool associativeEnabled
)
Public Shared Function CreateOffsetSurface (
entity As Entity,
offsetDistance As Double,
associativeEnabled As Boolean
) As ObjectId
public:
static ObjectId CreateOffsetSurface(
Entity^ entity,
double offsetDistance,
bool associativeEnabled
)
static member CreateOffsetSurface :
entity : Entity *
offsetDistance : float *
associativeEnabled : bool -> ObjectId
Parameters
- entity Entity
- [in] Surface to be offset.
- offsetDistance Double
- [in] Offset distance.
- associativeEnabled Boolean
- [in] Indicates whether patch surface associativity is
enabled.
Return Value
ObjectId
Object identifier of an offset surface.
Remarks
This method is
implemented only for the Spatial modeler.
See Also