Polyline3dInsertVertexAt(PolylineVertex3d,
PolylineVertex3d) Method
|
Inserts the specified vertex entity to this
polyline entity after the specified vertex, and makes this polyline
its owner.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertVertexAt(
PolylineVertex3d indexVertex,
PolylineVertex3d newVertex
)
Public Sub InsertVertexAt (
indexVertex As PolylineVertex3d,
newVertex As PolylineVertex3d
)
public:
void InsertVertexAt(
PolylineVertex3d^ indexVertex,
PolylineVertex3d^ newVertex
)
member InsertVertexAt :
indexVertex : PolylineVertex3d *
newVertex : PolylineVertex3d -> unit
Parameters
- indexVertex PolylineVertex3d
- [in] Vertex after which to insert the specified vertex.
- newVertex PolylineVertex3d
- [in] Vertex to insert.
Remarks
The vertex is made
database-resident. If this polyline entity is not
database-resident, the vertex is made database-resident when the
polyline is made database-resident. To insert the specified vertex
at the start of this polyline, use a nullptr for vertexId.
See Also