LayerStateManagerLayerStatesDictionaryId
Method
|
Gets the layer state dictionary ID if present
in the current database. The layer state dictionary can be created
if it is not present and the bCreateIfNotPresent parameter is set to true.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId LayerStatesDictionaryId(
bool createIfNotPresent
)
Public Function LayerStatesDictionaryId (
createIfNotPresent As Boolean
) As ObjectId
public:
ObjectId LayerStatesDictionaryId(
bool createIfNotPresent
)
member LayerStatesDictionaryId :
createIfNotPresent : bool -> ObjectId
Parameters
- createIfNotPresent Boolean
- [in] Create a layer state dictionary if it is not present in
the current database.
Return Value
ObjectId
The layer state dictionary ID if it is present in the current
database or the
bCreateIfNotPresent
parameter is set to
true, Null
otherwise.
See Also