Solid3dShellBody Method

Transforms the solid into a thin-walled solid shell by offsetting faces.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void ShellBody(
        SubentityId[] subentityIds,
        double offsetDistance
)

Parameters

subentityIds  SubentityId
[in] Face's subentity ID in the solid.
offsetDistance  Double
[in] Offset distance of each face.
Remarks
Offset can have an outside or inside direction related to the solid, depending on the sign of the offsetDistance parameter: * Positive value represents an outside direction. * Negative value represents an inside direction. If a face has surfaces that cannot be offset by the thickness, it is removed from the solid. A removal wound is healed with the surrounding face surfaces. Edges and vertices on the specified faces are merged if possible. Isolated edges in tweaked faces and neighboring faces may degenerate to points and therefore are removed. However, when removing loops or faces, insertion of edges or other topology changes are prohibited. This operation can cause the solid to become invalid in some cases. This method is implemented only for the Spatial modeler.
See Also

©  Bricsys NV. All rights reserved.