Sets the value for the specified entry in this
Dictionary object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId SetAt(
string searchKey,
DBObject newValue
)
Public Function SetAt (
searchKey As String,
newValue As DBObject
) As ObjectId
public:
ObjectId SetAt(
String^ searchKey,
DBObject^ newValue
)
member SetAt :
searchKey : string *
newValue : DBObject -> ObjectId
Parameters
- searchKey String
- [in] Name of entry to change.
- newValue DBObject
- [in] Database object to add.
Return Value
ObjectId
Returns the object ID of the newly added entry.
Remarks
If an entry with
the specified name exists in the dictionary, it is erased, and a
new entry is created. If an entry with the specified name does not
exist in this dictionary, a new entry is created.
See Also