AssocNetworkGetInstanceFromDatabase
Method
|
Returns an object ID of the associated network
owned by the given database. It optionally creates a new instance
if it does not exist yet.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static ObjectId GetInstanceFromDatabase(
Database database,
bool createIfDoesNotExist,
string dictionaryKey
)
Public Shared Function GetInstanceFromDatabase (
database As Database,
createIfDoesNotExist As Boolean,
dictionaryKey As String
) As ObjectId
public:
static ObjectId GetInstanceFromDatabase(
Database^ database,
bool createIfDoesNotExist,
String^ dictionaryKey
)
static member GetInstanceFromDatabase :
database : Database *
createIfDoesNotExist : bool *
dictionaryKey : string -> ObjectId
Parameters
- database Database
- [in] Database that owns the network.
- createIfDoesNotExist Boolean
- [in] Specifies whether to create a new subdictionary under the
named object dictionary of the database.
- dictionaryKey String
- [in] The name of the sub-dictionary under which the network
belongs. If the this parameter is empty, the default dictionary is
used.
Return Value
ObjectId
Object identifier of the existing or newly created associative
network.
See Also