PageParams Class

This class stores the printing page size and margins. All values are specified in millimeters.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GraphicsSystemPageParams

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class PageParams : DisposableWrapper

The PageParams type exposes the following members.

Constructors
  Name Description
Public method PageParams Default constructor for the PageParams class. Constructs an object with the following characteristics: * Paper width of the page = 210 * Paper height of the page = 297 * Left margin of the page = 0 * Right margin of the page = 0 * Top margin of the page = 0 * Bottom margin of the page = 0
Public method PageParams(PageParams) Copy constructor for the PageParams class. Copies the input page parameters.
Top
Properties
  Name Description
Public property BottomMargin  
Public property LeftMargin  
Public property PaperHeight  
Public property PaperWidth  
Public property RightMargin  
Public property TopMargin  
Top
Methods
  Name Description
Public method scale Scales the page parameters by the specified scale factor.
Public method setParams(Double, Double) Sets the width and height of the page.
Public method setParams(Double, Double, Double, Double, Double, Double) Sets the page parameters.
Top
See Also

©  Bricsys NV. All rights reserved.