BlockifyReplaceGeometryByBlocks
Method
|
Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version:
24.0.1.0
Syntax
public static ObjectIdCollection ReplaceGeometryByBlocks(
MatchingGeometrySets similarGroups,
bool useDefPoint,
string blockName,
ObjectId blockId,
Matrix3d blockTrans
)
Public Shared Function ReplaceGeometryByBlocks (
similarGroups As MatchingGeometrySets,
useDefPoint As Boolean,
blockName As String,
blockId As ObjectId,
blockTrans As Matrix3d
) As ObjectIdCollection
public:
static ObjectIdCollection^ ReplaceGeometryByBlocks(
MatchingGeometrySets^ similarGroups,
bool useDefPoint,
String^ blockName,
ObjectId blockId,
Matrix3d blockTrans
)
static member ReplaceGeometryByBlocks :
similarGroups : MatchingGeometrySets *
useDefPoint : bool *
blockName : string *
blockId : ObjectId *
blockTrans : Matrix3d -> ObjectIdCollection
Parameters
- similarGroups MatchingGeometrySets
-
- useDefPoint Boolean
-
- blockName String
-
- blockId ObjectId
-
- blockTrans Matrix3d
-
Return Value
ObjectIdCollection
See Also