ObjectIdCollection Class

This class represents a collection of ObjectId objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesObjectIdCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class ObjectIdCollection : DisposableWrapper, 
        IList

The ObjectIdCollection type exposes the following members.

Constructors
  Name Description
Public method ObjectIdCollection Default constructor for the ObjectIdCollection class.
Public method ObjectIdCollection(ObjectId) Constructor for the ObjectIdCollection class. Creates a collection from an array of ObjectId objects.
Top
Properties
  Name Description
Public property Count Property that represents the count of object identifiers in this collection.
Public property Item Property that represents an object identifier at the specified index of the collection.
Top
Methods
  Name Description
Public method Add Adds an object identifier to the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified ObjectId object.
Public method CopyTo Copies this object identifier collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of ObjectId objects.
Public method IndexOf Returns the index of the object identifier in this collection that matches the specified object identifier.
Public method Insert Inserts the specified object identifier to the collection at the provided index.
Public method Remove Removes an item in the collection that matches the specified item.
Public method RemoveAt Removes an object identifier from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.