Constructor for the IdPair class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public IdPair(
ObjectId key,
ObjectId value,
bool isCloned,
bool isPrimary,
bool isOwnerTranslated
)
Public Sub New (
key As ObjectId,
value As ObjectId,
isCloned As Boolean,
isPrimary As Boolean,
isOwnerTranslated As Boolean
)
public:
IdPair(
ObjectId key,
ObjectId value,
bool isCloned,
bool isPrimary,
bool isOwnerTranslated
)
new :
key : ObjectId *
value : ObjectId *
isCloned : bool *
isPrimary : bool *
isOwnerTranslated : bool -> IdPair
Parameters
- key ObjectId
- [in] Object ID to use as a key.
- value ObjectId
- [in] Object ID to use as a value.
- isCloned Boolean
- [in] Flag that specifies whether the key object has been
cloned.
- isPrimary Boolean
- [in] Flag that specifies whether the key object is
primary.
- isOwnerTranslated Boolean
- [in] Flag that specifies whether the owner of the key object
has been translated.
See Also