IdPair Structure

This class is the element class for IdMapping, which is used in deepclone operations to map object IDs from the original objects to their clones. Key is the object ID of the original object. Value is the object ID of the cloned object.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesIdPair

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct IdPair

The IdPair type exposes the following members.

Constructors
  Name Description
Public method IdPair Constructor for the IdPair class.
Top
Properties
  Name Description
Public property IsCloned Property that indicates whether the key object has been cloned.
Public property IsOwnerTranslated Property that indicates whether the owner of the key object has been translated.
Public property IsPrimary Property that indicates whether the key object is primary.
Public property Key Property that represents the key object ID.
Public property Value Property that represents the value object ID.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(IdPair, IdPair) Equality operator for the IdPair class.
Public operatorStatic member Inequality(IdPair, IdPair) Inequality operator for the IdPair class.
Top
See Also

©  Bricsys NV. All rights reserved.